Page 1 of 2

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 9:47 am
by RonPerry
I am unable to start my SS1 1800 ti and have no sparks at the plugs. I was driving along normally and the car cut out as if the ignition was switched off. This happened twice but now car wont start at all. I've tried some basis checks but have limited knowledge! I took it (towed) to my local garage but after two weeks they were no further forward - car a bit too old for their knowledge.

Just wondering if anyone is aware of any garages that have the skill and knowledge to fix it (I certainly haven't). I am in Bristol but appreciate I may have to trailer it elsewhere.

Suggestions of who could diagnose/fix it most welcome as its just taking up garage space at the moment and I love driving it!

Ron
07951415365

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 9:52 am
by scimjim
Give Andy (AJL Electronics) a bell, he may have a space coming up?

my suspicions would be ignition switch or optical pickup in the dizzy but I would have thought a garage would have found a manual for the car and done those basic checks?

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 11:07 am
by old bean
Sounds just like a duff distributor sensor.

If it is the sensor and you need to source one, try here https://www.rockauto.com/en/moreinfo.ph ... 29&jsn=370

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 12:04 pm
by peter freeman
Try contacting Mark Wilson for dizzy spares - otherwise it could be the coil which is cheaper to try first and if not the problem you have a spare in stock.

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 12:32 pm
by td99
check the separate (not in fuse-box) relay under the brake master cvl is operating ok, it supplies power to the coil/transistor via a wire across rear of engine bay.

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 12:58 pm
by mikeh
I've had fun with my non starting Ti and have found that I had a duff Darlington transistor. (I replaced it but that was duff so waiting for a new one).
How handy are you with a multimeter / spanners ?
There are some very simple checks that you can do to narrow it down.
I would check the following first.
Do you have 12v to the connector before the coil ? Does the coil get hot if you leave it on. ? then you have a supply to the coil.
Remove the dizzy making the appropriate markings to replace it in the correct position.
Slowly turn it to see if the fuel pump is working (There are two optical sensors inside the dizzy one for crankshaft position and one for the fuel pump).
You'll hear the injectors fire at roughly every 90 degrees.
If the pump works then if you look at my thread and check if the supply and feed to the optical sensor is working using a multimeter at the dizzy connector, again this is described in my thread. if that gives a good result then I'd check the darlington resistor. The process is in the Nissan manual very simple.
The supply from the dizzy for the crankshaft position sensor side of the dizzy is difficult to check you have to turn the dizzy very slowly and you will see if the optical sensor is working.

I've got all the relevant bits down where the car is and can collect them and scan if you need them.

Cheers

Mike

SS1 1800 Ti No Sparks

Posted: Mon Apr 29, 2019 2:41 pm
by RonPerry
Thanks for all the replies. I've booked the car in at AJL Electronics for Friday so fingers crossed!
Ron

SS1 1800 Ti No Sparks

Posted: Fri May 03, 2019 2:27 pm
by AJL Electronics
Initial investigations confirm the symptoms. No sparks turning over but when the key is released and the engine stops turning, it wil give one or two sparks. Looking at it later after my back improves from pushing it into the workshop!

SS1 1800 Ti No Sparks

Posted: Fri May 03, 2019 6:14 pm
by mikeh
I'll be interested in what's wrong with it. Going to refit the Darlington resistor assembly on mine tomorrow and it should run as all the symptoms point to that.

SS1 1800 Ti No Sparks

Posted: Fri May 03, 2019 7:34 pm
by AJL Electronics
The Darlington array is a transistor ( well 2 really but in the same case.). The Darlington configuration allows for very high gain with high impedance input.

SS1 1800 Ti No Sparks

Posted: Fri May 03, 2019 8:46 pm
by gtcse8
I have stock of Crank Angle Sensors at £58 inc posting.
They actually have Two optical sensors fitted.
IIRC One reads TDC for the fuel pump to start up and to tell the ecu to start looking for the Second eye which reads the 360dg for the firing of the injectors and ignition.
I can also do a substitution test over a couple of days If I get a "Suspect" dizzy for a nominal cost.

Peter`s spare dizzy only failed when it was warm, and another dizzy just stopped at random.

Be warned about putting 12v battery voltage through it though, they don`t like spikes OR more than 5v through any of the wires.

Best to check for correct operation is to set the engine to TDC on No 1 cylinder.
Remove the cap and disconnect the dizzy.
Mark the relative positions of the dizzy body to engine block and the rotor arm.
Remove dizzy and refit the cap and wiring.
Turn ignition ON and spin the drive gear.
The fuel pump should start up and you should be able to hear the injectors firing and a slight crackling for the sparks.

SS1 1800 Ti No Sparks

Posted: Tue May 07, 2019 10:27 am
by RonPerry
AJL Electronics wrote:
Fri May 03, 2019 2:27 pm
Initial investigations confirm the symptoms. No sparks turning over but when the key is released and the engine stops turning, it wil give one or two sparks. Looking at it later after my back improves from pushing it into the workshop!
Sorry about the bad back Andy!
Ron

SS1 1800 Ti No Sparks

Posted: Tue May 07, 2019 10:45 am
by philhoward
It isn’t something daft like the switch unit on the back of the ignition lock losing the ignition feed during cranking?

SS1 1800 Ti No Sparks

Posted: Mon May 20, 2019 5:11 pm
by RonPerry
Picked up SSI from Andy at AJL Electronics in Gloucester today. Fault diagnosed and new part sourced and fitted! Great service, thanks Andy. Good drive home, MOT booked for tomorrow.
Fault was an optical sensor failure in the distributor.

SS1 1800 Ti No Sparks

Posted: Mon May 20, 2019 7:17 pm
by dypcdiver
Thanks for the update, it's nice to know the cause, all good knowledge to file away.