Sabre 1800Ti Problems Starting

Discuss and exchange views and technical information about our cars.

Moderators: scimjim, erikscimitardemon, Lukeyboy46, Roger Pennington, philhoward

Post Reply
User avatar
big_billc
RSSOC Member
Posts: 80
Joined: Tue Jul 19, 2011 12:39 pm
Location: Croydon, Surrey
Has thanked: 2 times

Sabre 1800Ti Problems Starting

Post by big_billc » Wed Aug 17, 2016 8:11 am

Hi All,
I won't be bringing my Sabre to Curborough as it will not start, and everything tried has not been successful. I just bought a new coil off of eBay to try that (good price : - link below £10.99) It occurred to me a spare ECU would be useful. If anybody has a ECU they want to sell please phone me on 0770 699 7980 at Curborough if you can bring it, otherwise send me a pm for after the weekend.
See some of you there
http://www.ebay.co.uk/itm/291181005302


Old English White SE6A 2.9 EFI, Subaru White Sabre 1800Ti, Dark Grey Saab 9-3 My Scimitar spares collection car.
Problems : - Find a problem, Sort a problem, now there is no problem.

User avatar
big_billc
RSSOC Member
Posts: 80
Joined: Tue Jul 19, 2011 12:39 pm
Location: Croydon, Surrey
Has thanked: 2 times

Re: Sabre 1800Ti Problems Starting

Post by big_billc » Thu Sep 01, 2016 11:23 pm

Still unable to start the car.
I have borrowed an ECU to test: - no difference
I have by bypassed the ECU on the fuel pump taking it to earth so not to the ECU to test: - no difference
I have tried a new coil to test: - no difference
I have changed the plug gap from handbook 39mm to 25mm: - no difference
I have fuel after the filter, but does not appear to be getting to the plugs: - no difference
I will try seeing if the plugs are covered with fuel tomorrow
I am particularly worried about a noise very close to 3 &4 plugs which is a hissing similar to the fuel pump noise but also similar to escaping air.

Any ideas at all would be very welcome including a home visit to fix - Payment negotiable !!!


Old English White SE6A 2.9 EFI, Subaru White Sabre 1800Ti, Dark Grey Saab 9-3 My Scimitar spares collection car.
Problems : - Find a problem, Sort a problem, now there is no problem.

old bean
Posts: 221
Joined: Tue Aug 31, 2010 12:28 am
Been thanked: 9 times

Re: Sabre 1800Ti Problems Starting

Post by old bean » Thu Sep 01, 2016 11:53 pm

Do you have a spark at the plugs? From memory you want a 0.70mm ish plug gap?

If no spark check your rotor cap and rotor arm condition, also HT lead from coil to cap.
If that's ok try a new ground wire to your coil from the engine block
Check Dizzy wiring connectors are not loose
Your Dizzy sensor could be at fault, intermittent ignition failure when warm would have been a give away syndrome of this about to happen
Obviously check all the fuses too.

If you have a spark, have you had the dizzy out and inserted it out of time? Have you had the cambelt off and miss timed that?

If you have a spark and the plugs are wet, pull the fuel pump fuse and crank the engine to clear excess fuel. Put fuse back and try to start.

What has happened to the car since it last ran? Was it just parked up as a runner and now won't start or have you had it all to bits?

Injector pulse requires a reading from the dizzy optical sensor so that could well be your trouble if you've got fuel to the rail but not the plugs.



User avatar
sabre1800ti
RSSOC Member
Posts: 324
Joined: Wed Jun 27, 2007 4:32 pm
Location: Wirral,Cheshire
Has thanked: 11 times
Been thanked: 4 times

Re: Sabre 1800Ti Problems Starting

Post by sabre1800ti » Fri Sep 02, 2016 8:18 am

Did you check the ECU fault codes before & after changing ECU.
Optical sensor is fault code 11, if I remember correctly.
I have had an optical sensor fail on the Sabre & a S12 Silvia so it is not that uncommon.


Doug Black
Ex-Factory 1993 Scimitar Sabre 1800Ti Mk 1

User avatar
philhoward
RSSOC Member
Posts: 25143
Joined: Tue Aug 29, 2006 5:41 pm
Location: Staffs, UK
Has thanked: 58 times
Been thanked: 624 times
Contact:

Re: Sabre 1800Ti Problems Starting

Post by philhoward » Fri Sep 02, 2016 8:48 am

I'm suspecting an optical pickup failure too.


Phil Howard
Scimitarweb Forum Admin
SS1 1600 Rooster Turbo; Sabre Mk1.5, Sabre Mk2
Previous: SE5/5a/SS1 No.1/SS1 Rooster/SS1 1800Ti/SE5a 24 Valve
http://www.ss1turbo.com
Never try and argue with an idiot. They drag you down to their level, then beat you based on experience.

User avatar
Corky
RSSOC Member
Posts: 11205
Joined: Sun Sep 24, 2006 5:02 am
Location: Macclesfield
Has thanked: 248 times
Been thanked: 209 times

Re: Sabre 1800Ti Problems Starting

Post by Corky » Fri Sep 02, 2016 9:47 am

You haven't by any chance removed a fuse from the fuse box that looks like it's a spare ?


Steve
Current:- SS1 Ti RG sprint car, Honda S2000, VW Touareg 3.0 V6
Prev:- Sabre Ti, 3xSS1 Ti, SS1 16v Turbo Racer, 5XGTC, 2XSE6B, 2XSE5A, 2XV6 Coupe, Sabre 6
Project Threads & YouTube

“It's not the winning, it's the taking apart that counts"

User avatar
Corky
RSSOC Member
Posts: 11205
Joined: Sun Sep 24, 2006 5:02 am
Location: Macclesfield
Has thanked: 248 times
Been thanked: 209 times

Re: Sabre 1800Ti Problems Starting

Post by Corky » Fri Sep 02, 2016 9:57 am

It's 15 on this photo :-

Image

The dark blue 15A one on the right 2nd row from the top.

Image


Steve
Current:- SS1 Ti RG sprint car, Honda S2000, VW Touareg 3.0 V6
Prev:- Sabre Ti, 3xSS1 Ti, SS1 16v Turbo Racer, 5XGTC, 2XSE6B, 2XSE5A, 2XV6 Coupe, Sabre 6
Project Threads & YouTube

“It's not the winning, it's the taking apart that counts"

User avatar
big_billc
RSSOC Member
Posts: 80
Joined: Tue Jul 19, 2011 12:39 pm
Location: Croydon, Surrey
Has thanked: 2 times

Re: Sabre 1800Ti Problems Starting

Post by big_billc » Mon Sep 12, 2016 6:52 pm

Can anybody tell me the ref number of the optical pickup? If this is difficult to find, can you direct me to where I can buy one?


Old English White SE6A 2.9 EFI, Subaru White Sabre 1800Ti, Dark Grey Saab 9-3 My Scimitar spares collection car.
Problems : - Find a problem, Sort a problem, now there is no problem.

User avatar
sabre1800ti
RSSOC Member
Posts: 324
Joined: Wed Jun 27, 2007 4:32 pm
Location: Wirral,Cheshire
Has thanked: 11 times
Been thanked: 4 times

Re: Sabre 1800Ti Problems Starting

Post by sabre1800ti » Mon Sep 12, 2016 7:07 pm

I got mine from RockAuto, they ship from California. They were the only ones I could find at the time, but others may know different.

Some part numbers, (I think they are correct)
INTERMOTOR LX653
FACET 7030
AIRTEX/WELLS 5S1864
NISSAN 802 38033 614


Doug Black
Ex-Factory 1993 Scimitar Sabre 1800Ti Mk 1

User avatar
big_billc
RSSOC Member
Posts: 80
Joined: Tue Jul 19, 2011 12:39 pm
Location: Croydon, Surrey
Has thanked: 2 times

Re: Sabre 1800Ti Problems Starting

Post by big_billc » Mon Sep 12, 2016 8:08 pm

Thanks Doug and all above. Found a link from years ago from Jim Russell he had identical problems, also Jim Kings link to RockAuto. The fault search continues,


Old English White SE6A 2.9 EFI, Subaru White Sabre 1800Ti, Dark Grey Saab 9-3 My Scimitar spares collection car.
Problems : - Find a problem, Sort a problem, now there is no problem.

User avatar
peter freeman
RSSOC Member
Posts: 9932
Joined: Thu Aug 31, 2006 12:12 pm
Location: Newcastle
Has thanked: 9 times
Been thanked: 356 times
Contact:

Re: Sabre 1800Ti Problems Starting

Post by peter freeman » Mon Sep 12, 2016 8:36 pm

I thought you had a spark Bill - if yes then its worth trying to spray the inside of the dizzy in case you have some dirt on the optics or rotor plate - contact cleaner from Maplins - not cleaner and lubricant - spray the dizzy and leave the cap off for a while to dry out. You may have a spark but if the rotor plate is dirty it may not be timed correctly.



Post Reply

Return to “General Technical Discussion”