Help please im new to this

Discuss and exchange views and technical information about our cars.

Moderators: scimjim, Lukeyboy46, erikscimitardemon, Roger Pennington, philhoward

Rwigley66
Posts: 34
Joined: Sun May 01, 2016 9:15 pm

Re: Help please im new to this

Post by Rwigley66 » Wed May 04, 2016 7:41 am

No luck so far tho



Rwigley66
Posts: 34
Joined: Sun May 01, 2016 9:15 pm

Re: Help please im new to this

Post by Rwigley66 » Thu May 05, 2016 9:07 pm

Will this fit my car does anyone know?http://www.burtonpower.com/weber-linkag ... p4232.html



Rwigley66
Posts: 34
Joined: Sun May 01, 2016 9:15 pm

Re: Help please im new to this

Post by Rwigley66 » Thu May 05, 2016 9:09 pm

I know its a dgas carb that i have but the linkage looks similar it may be a stupid question sorry



User avatar
scimjim
RSSOC Member
Posts: 38277
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 146 times
Been thanked: 1030 times

Re: Help please im new to this

Post by scimjim » Thu May 05, 2016 9:13 pm

Nope.


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

Rwigley66
Posts: 34
Joined: Sun May 01, 2016 9:15 pm

Re: Help please im new to this

Post by Rwigley66 » Thu May 05, 2016 9:55 pm

:( cant find one anywhere then lol



Rwigley66
Posts: 34
Joined: Sun May 01, 2016 9:15 pm

Re: Help please im new to this

Post by Rwigley66 » Sat May 14, 2016 6:39 pm

Thankyou supersub for helping me out with the carb juat need the throttle linkage and i will be up and running anyone got a spare one let me know cheers all



scimitargtc
RSSOC Member
Posts: 377
Joined: Sun Jun 14, 2009 9:05 am
Location: EAST YORKSHIRE UK
Has thanked: 2 times
Been thanked: 21 times

Help please im new to this

Post by scimitargtc » Sat Jun 08, 2019 11:47 am

Help, after a lot of messing about I’ve now got my 79a auto almost road ready, fuel started dribbling off the accelerator diaphragm so new fitted this morning, manual choke conversion now working properly for the first time since I installed it in 2000, but ca started for a few seconds at 3000rpm ! Figured the return spring on the back of the carb was pulling the quadrants Which obviously opened the carb flaps, so I’m trying to figure where the spring should be routed. Always believed it was correct attached to the fuel rail and then to the hole on the return bar on the carb, Jim’s photo shows the spring attached to the bar but just where does the other end attach to please


1979 se6a auto pas 3.0v6 (unnamed) sold after 22 years 2019.
1998 Range Rover 4.6 v8 auto (unnamed)
2016 Nissan QashQai 1.6 Tekna CVT dci ("Quentin")
2019 Skoda Cititgo MPI SEL Greentech ("Clyde")
Space for 5 more! Money for none!!

scimitargtc
RSSOC Member
Posts: 377
Joined: Sun Jun 14, 2009 9:05 am
Location: EAST YORKSHIRE UK
Has thanked: 2 times
Been thanked: 21 times

Help please im new to this

Post by scimitargtc » Sat Jun 08, 2019 11:59 am

Can see the hole in he bracket where the throttle cable goes through, all looks logical but the spring see photo is too long
Attachments
2ADF4FB3-5377-4760-B39F-DAAF78DD893B.jpeg
2ADF4FB3-5377-4760-B39F-DAAF78DD893B.jpeg (263.2 KiB) Viewed 463 times


1979 se6a auto pas 3.0v6 (unnamed) sold after 22 years 2019.
1998 Range Rover 4.6 v8 auto (unnamed)
2016 Nissan QashQai 1.6 Tekna CVT dci ("Quentin")
2019 Skoda Cititgo MPI SEL Greentech ("Clyde")
Space for 5 more! Money for none!!

justfur
RSSOC Member
Posts: 122
Joined: Thu Aug 18, 2016 7:42 pm
Location: Limerick Ireland
Has thanked: 4 times
Been thanked: 1 time

Help please im new to this

Post by justfur » Sat Jun 08, 2019 1:05 pm

Pretty sure this is the spring......

https://www.ebay.co.uk/itm/262062480296


Justin.

1976 SE6 no.49 See more here: https://www.flickr.com/photos/147918531 ... 463353942/

1963 CV8 Mk1 no.10
1967 TR4A

rebel alliance
Posts: 920
Joined: Thu Mar 03, 2016 9:20 pm
Has thanked: 10 times
Been thanked: 62 times

Help please im new to this

Post by rebel alliance » Sat Jun 08, 2019 1:10 pm

Yeah wrong spring...where does that black pipe between the throttle quadrants go to ?



scimitargtc
RSSOC Member
Posts: 377
Joined: Sun Jun 14, 2009 9:05 am
Location: EAST YORKSHIRE UK
Has thanked: 2 times
Been thanked: 21 times

Help please im new to this

Post by scimitargtc » Sat Jun 08, 2019 1:17 pm

Thanks, that spring has been on the car for 21 years I’ve owned the car so new 1 that is correct now ordered. The pipe is attached onto a stub at the back of the carb to a stub on the side (& yes it’s been pointed out the W spacer is 180 degrees out :oops: :oops: )


1979 se6a auto pas 3.0v6 (unnamed) sold after 22 years 2019.
1998 Range Rover 4.6 v8 auto (unnamed)
2016 Nissan QashQai 1.6 Tekna CVT dci ("Quentin")
2019 Skoda Cititgo MPI SEL Greentech ("Clyde")
Space for 5 more! Money for none!!

rebel alliance
Posts: 920
Joined: Thu Mar 03, 2016 9:20 pm
Has thanked: 10 times
Been thanked: 62 times

Help please im new to this

Post by rebel alliance » Sat Jun 08, 2019 2:49 pm

So it comes off the throttle quadrant vacuum stub and connects onto where ?



Post Reply

Return to “General Technical Discussion”