SS1 at Silverstone, but in the car-park

Seen a Scimitar somewhere? Let them know and maybe make contact locally.

Moderators: scimjim, philhoward, erikscimitardemon, Roger Pennington, Lukeyboy46

Post Reply
User avatar
jondwyer
Posts: 622
Joined: Tue Oct 20, 2009 5:57 pm
Location: Buckingham
Has thanked: 7 times
Been thanked: 6 times

SS1 at Silverstone, but in the car-park

Post by jondwyer » Sun Oct 22, 2017 8:21 pm

Seen today, in black. Badge said 1600 but it had a Ti bootlid spoiler
20171022_132227.jpg
20171022_132227.jpg (70.58 KiB) Viewed 873 times
I'd get those headlamps to go back down, if it were mine...



User avatar
scimjim
RSSOC Member
Posts: 34298
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 110 times
Been thanked: 708 times

SS1 at Silverstone, but in the car-park

Post by scimjim » Sun Oct 22, 2017 10:03 pm

Not on the database - you need to go back and find the owner and get the VIN :)


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
jondwyer
Posts: 622
Joined: Tue Oct 20, 2009 5:57 pm
Location: Buckingham
Has thanked: 7 times
Been thanked: 6 times

SS1 at Silverstone, but in the car-park

Post by jondwyer » Tue Oct 24, 2017 10:53 pm

Sorry, Jim, we only get a 40-minute lunch-break so it was a quick photo en route to the cafe!



User avatar
reliant-reviver
RSSOC Member
Posts: 4390
Joined: Thu Jun 14, 2007 8:05 pm
Location: Beighton, Sheffield
Has thanked: 49 times
Been thanked: 83 times

SS1 at Silverstone, but in the car-park

Post by reliant-reviver » Wed Oct 25, 2017 10:05 am

Is that not the 1800ti that sold on Ebay a few months back for circa 1200, original factory black with lacquer shot. Reg rings a bell.


Philip Andrew.
'84 SS1 1300, '86 SS1 1800ti, '87 SS1 1300
Previous: Too many!

User avatar
reliant-reviver
RSSOC Member
Posts: 4390
Joined: Thu Jun 14, 2007 8:05 pm
Location: Beighton, Sheffield
Has thanked: 49 times
Been thanked: 83 times

SS1 at Silverstone, but in the car-park

Post by reliant-reviver » Wed Oct 25, 2017 10:07 am

Scratch that. I'm thinking of this one -
viewtopic.php?f=23&t=36645&p=423513

The "PLO" letters in the reg appear on plenty of cars from the memory, perhaps why it feels familiar.


Philip Andrew.
'84 SS1 1300, '86 SS1 1800ti, '87 SS1 1300
Previous: Too many!

User avatar
reliant-reviver
RSSOC Member
Posts: 4390
Joined: Thu Jun 14, 2007 8:05 pm
Location: Beighton, Sheffield
Has thanked: 49 times
Been thanked: 83 times

SS1 at Silverstone, but in the car-park

Post by reliant-reviver » Wed Oct 25, 2017 10:10 am

"Placed" the familiar feeling. Trawled the dustbin (ock aye, don't start that one up again Phil)

viewtopic.php?f=24&t=35899

Apparently the P.O. mailed the deets to the registrar. Hmm.


Philip Andrew.
'84 SS1 1300, '86 SS1 1800ti, '87 SS1 1300
Previous: Too many!

pdriley
Posts: 21
Joined: Fri Mar 03, 2017 5:57 pm

SS1 at Silverstone, but in the car-park

Post by pdriley » Fri Oct 27, 2017 9:00 am

It's mine. Had since April this year. It is 1600 but original owner ordered the diamond wheels as optional extra and I've added a Sabre spoiler. My everyday car - except headlights keep going up and down out of sync despite QRG's endeavours. Hence why permanently up at the moment! Enjoyable day at Silverstone watching the historic car racing.



User avatar
jondwyer
Posts: 622
Joined: Tue Oct 20, 2009 5:57 pm
Location: Buckingham
Has thanked: 7 times
Been thanked: 6 times

SS1 at Silverstone, but in the car-park

Post by jondwyer » Fri Oct 27, 2017 5:33 pm

Enjoyable day, likewise, putting out a major fire at Becketts!



User avatar
Roger Pennington
RSSOC Member
Posts: 19013
Joined: Tue Aug 29, 2006 9:43 pm
Has thanked: 106 times
Been thanked: 432 times

SS1 at Silverstone, but in the car-park

Post by Roger Pennington » Fri Oct 27, 2017 7:34 pm

pdriley wrote:
Fri Oct 27, 2017 9:00 am
My everyday car - except headlights keep going up and down out of sync despite QRG's endeavours. Hence why permanently up at the moment!
Mine did that when I first got the car, dismantling the limit switches (on the side of each motor) and cleaning the contacts sorted it out, and regular use seems to help :) Good to hear it's in regular daily use too, it's a smart-looking car!


....Roger

RSSOC member (since 1982)
- - - - - - - - - - - - - - - - -
Image

"Condition can be bought at any time; Originality, once lost, is gone forever" - Doug Nye

pdriley
Posts: 21
Joined: Fri Mar 03, 2017 5:57 pm

SS1 at Silverstone, but in the car-park

Post by pdriley » Thu Nov 02, 2017 3:18 pm

Many thanks for the advice.



User avatar
Alan SS1
Posts: 1763
Joined: Sun Nov 21, 2010 9:58 pm
Location: BoD, Aberdeen
Has thanked: 21 times
Been thanked: 26 times
Contact:

SS1 at Silverstone, but in the car-park

Post by Alan SS1 » Thu Nov 02, 2017 8:42 pm

Roger Pennington wrote:
Fri Oct 27, 2017 7:34 pm
and cleaning the contacts sorted it out, and regular use seems to help :) Good to hear it's in regular daily use too, it's a smart-looking car!
yep regular use seems to help, the contacts are in a 'less than ideal' location ditto with the 480, always spend the week or so before MoT turning light on & off before set off for every journey (the motors and switches are enclosed in a PU rubber condom/shrink sleeve, so can't access the switches)


SS1 1600 (AJZ ----), Regal 330 (VAV ---), C30 (SK 57 ---)& 480 (EVU ---)

Post Reply

Return to “Scimitar Sightings”