Main beam question

Moderators: scimjim, Roger Pennington, Lukeyboy46, philhoward, erikscimitardemon

Post Reply
Alan_GTC
Posts: 43
Joined: Tue Jun 05, 2012 7:20 pm
Been thanked: 1 time

Main beam question

Post by Alan_GTC » Wed Apr 12, 2017 4:24 pm

Hi -

Just completed replacement of all the front lights on my C - having taken them out to get to the blower motors, decided full replacement was in order owing to the condition of what I took off....

Now, the question - when I put main beam on initially only the two inners come on, but if you 'tap' the switch all four lights come on as main beam - my thought is worn / poor contact in the switch - any other ideas ? I've already messaged Mark (GTCSE8) to see if he still has stock of them as a precaution....



User avatar
scimjim
RSSOC Member
Posts: 33346
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 107 times
Been thanked: 640 times

Re: Main beam question

Post by scimjim » Wed Apr 12, 2017 4:31 pm

Definitely sounds like the switch. IIRC the spot/fog light switch is the same 2 pole arrangement, so can be swapped for diagnostics?


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

Alan_GTC
Posts: 43
Joined: Tue Jun 05, 2012 7:20 pm
Been thanked: 1 time

Re: Main beam question

Post by Alan_GTC » Wed Apr 12, 2017 5:42 pm

Sorry, should have been clear, the switch in question is the main beam / indicator one, not the headlight switch.

The stalk feels a little slack, hence guessing the contacts are worn.....



User avatar
peter freeman
RSSOC Member
Posts: 8712
Joined: Thu Aug 31, 2006 12:12 pm
Location: Newcastle
Has thanked: 9 times
Been thanked: 250 times
Contact:

Re: Main beam question

Post by peter freeman » Wed Apr 12, 2017 5:50 pm

There are two blue/white wires that come from the switch - one directly to the inner lights and the other to the main beam relay. I don't know off hand where the two wires come together but if tapping the column switch makes a difference then that's where to start looking.



User avatar
scimjim
RSSOC Member
Posts: 33346
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 107 times
Been thanked: 640 times

Re: Main beam question

Post by scimjim » Wed Apr 12, 2017 6:08 pm

Yep - just been going through this with DJs 6b. The flash function powers the inners directly as Peter says, it also makes the main beam relay behind the glove box which powers the outers. Still sounds like a dodgy contact though - watch out for springs if you take the stalks apart :-)


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

ronnie
Posts: 873
Joined: Tue Aug 10, 2010 5:38 pm
Location: Lanarks,Scotland
Has thanked: 48 times
Been thanked: 35 times

Re: Main beam question

Post by ronnie » Wed Apr 12, 2017 6:13 pm

I've just repaired the column headlight switch at the weekend after thinking it was front fuse panel wires that I had disturbed.

You can take the switch apart just like the main headlight and fog switch on the central panel.

A couple of (bent) rocker arm brass plates within the switch could be the problem area.
There are 2 tiny,tiny, very tiny springs within the plastic pins under the rocker



ronnie
Posts: 873
Joined: Tue Aug 10, 2010 5:38 pm
Location: Lanarks,Scotland
Has thanked: 48 times
Been thanked: 35 times

Re: Main beam question

Post by ronnie » Fri Apr 21, 2017 7:20 am

Was the problem solved?

What was the fix?



Alan_GTC
Posts: 43
Joined: Tue Jun 05, 2012 7:20 pm
Been thanked: 1 time

Re: Main beam question

Post by Alan_GTC » Fri Apr 21, 2017 9:45 am

Well, I found a Chevette column switch on fleabay so have bought that - awaiting delivery.

If I find it's in better condition than mine - ie. less slack in the switch, then I'll swap and see if the problem goes away. Then will look to refurb the old one so I have a spare.

That's the plan at the moment....



Post Reply

Return to “Se6/6a/6b/GTC”