Project Green and Cream Update!!

Moderators: scimjim, Lukeyboy46, Roger Pennington, philhoward, erikscimitardemon

Post Reply
User avatar
vinetvinyle
Posts: 57
Joined: Sat May 28, 2016 10:38 pm
Location: Altrincham
Has thanked: 17 times

Project Green and Cream Update!!

Post by vinetvinyle » Sat Dec 24, 2016 1:03 pm

Two months ago I had a late night rant on here after destroying the starter on the scimitar aswell as the points and timing... :|

I said that was it, enough was enough, the money pit rumours were true!

Two months later mould was starting to grow in the boot so I got the credit card out, thought screw Christmas, and got the thing taken to the local garage.... :shock:

So £1250 lighter this is where i'm up to with project Scim.

First jobs I did were trying to get rid of this VERY intermittent electrical cutting out fault that was driving me mad, it ended up being the Accuspark electronic ignition the previous owner had fitted.... so on with brand new points, distributor, rotor arm, ht leads, plugs, coil and all associated wiring which I did myself. Timing set up at the garage, starter motor had just worked loose so no dramas there... fired up first turn of the key and no cutting out since :D

The MOT had expired in this time though sadly so down to the test station... Failed on - Steering rack gaiter, passenger door not opening (it was locked... wish i was joking), indicators and hazards not working (biggest pain in the arse ever) handbrake, front brakes not good enough...

So back brakes nice and easy, all apart, cleaned, cables adjusted, back together and now good as gold.

Steering rack gaiter, same.

Passenger door, unlocked.

Indicators... what a faff... The hazard switches are a bit of a commodity it would appear so after trying to clean up old one it still didn't work, bought another of QRG for £20 plus postage :oops: that one was also knackered... decided to visit local MG guy and bought a brand new round pin jobby and replaced the old terminals with nice new ones and made a little adapter to fit in old hole. looks the part to be fair! Now indicators working if a bit slow... replaced flasher unit, still slow... but fine possibly just being picky!

Front brakes.... Nightmare, both calipers had in all fairness served their time and needed replacing due to seizing etc, these are also a commodity that anyone whose tried to find any will tell you!! so £220 later two brand new ones had been found, new discs and pads also fitted and now the brakes are spot on.

12 MONTHS MOT PASSED NO ADVISORIES!!

Whilst it was in the garage and the credit card was out we also decided to get a few other jobs done... All new sump, rockers, front casing and a few other gaskets replaced. Tappets gapped, carb properly set up, cleaned, auto choke sorted and throttle cable re routed so it now starts on the button and ticks over beautifully at idle once warmed up. Oil and filter replaced and a few other minor jobs completed. Also replaced a weeping core plug.

So now the car is mechanically almost perfect, the overdrive has suddenly stopped working though so i'll be investigating that soon (any tips on what to look for are always greatly received!)

Next on the list as soon as possible - all new door and boot seals as the back window leaks like a waterfall and the drivers side window regulator has also decided to eat itself. Take the guage bit of dash out, repair cracks, clean and refinish all dials, replace all dash bulbs and tidy ALL the wiring, investigate asthmatic blower box. As soon as thats all done it can finally have some paint, interior trim and some exterior chrome!! Then fingers crossed i'll have a nice little SE5a for the summer shows!!

Thanks for reading, if TL;DR i can summarise by saying - spent a lot of time and money = car now good.

MERRY CHRISTMAS RELIANT GUYS! :mrgreen: :mrgreen: :mrgreen:


[album]1671[/album]

User avatar
scimjim
RSSOC Member
Posts: 38045
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 140 times
Been thanked: 995 times

Re: Project Green and Cream Update!!

Post by scimjim » Sat Dec 24, 2016 1:23 pm

Well done on the MOT :-)

Did you fit an electronic flasher unit? They don't rely on the earth at the bulb holder.

Normally I'd say check gearbox oil level first for an overdrive fault but if it's stopped suddenly it's more likely to be electrical, so check solenoid, inhibit switch and dash switch wiring first.


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
vinetvinyle
Posts: 57
Joined: Sat May 28, 2016 10:38 pm
Location: Altrincham
Has thanked: 17 times

Re: Project Green and Cream Update!!

Post by vinetvinyle » Sun Dec 25, 2016 11:58 pm

Cheers scimjim I'll try those and hopefully get it sorted!


[album]1671[/album]

User avatar
peter freeman
RSSOC Member
Posts: 9959
Joined: Thu Aug 31, 2006 12:12 pm
Location: Newcastle
Has thanked: 9 times
Been thanked: 357 times
Contact:

Re: Project Green and Cream Update!!

Post by peter freeman » Mon Dec 26, 2016 9:08 am

I would look at the OD inhibit switch first as well - they often stick as they are not that easy to get at to be lubricated. Failing that check power is getting to the solenoid anyway and if it is remove the solenoid - clean it and stretch the springs slightly as they get weaker with age - like us all.



User avatar
toomanysabres
RIP
Posts: 5373
Joined: Sun Nov 12, 2006 1:27 pm
Location: Leatherhead
Has thanked: 14 times
Been thanked: 88 times

Re: Project Green and Cream Update!!

Post by toomanysabres » Mon Dec 26, 2016 10:21 am

That also applies to bed springs if you have been eating too much Christmas pudding :lol:


Now: '62 Sabre 4, '63 Sabre Six, '65 SE4, '00 BMW E38 740i sport.
Prev: '53 ZephyrZodiac, '64 Sabra GT, '68 Elan S3SE, Mk3 Cortina 2000GXL, Mk4 Cortina 2000 Est, 3 SE6a's, 2 SE5a, SE4a Turbo, 1800Ti.
Company: Cav SRi, Cav SRi 130, Honda Concerto 1.6 (yuk)

User avatar
vinetvinyle
Posts: 57
Joined: Sat May 28, 2016 10:38 pm
Location: Altrincham
Has thanked: 17 times

Re: Project Green and Cream Update!!

Post by vinetvinyle » Wed Dec 28, 2016 10:32 pm

Ha! Yes I'll do that. Took the car to GW today had a good chat with him, picked up all new boot and rear hatch seals, door seals and weather strips etc, new bulbs for the dash clocks, new battery... Hoping to fit it all soon. According to the forum though it seems the rear hatch seal is a pig of a job, it was about 2 degrees outside today all day so not looking forward to the job much!


[album]1671[/album]

User avatar
peter freeman
RSSOC Member
Posts: 9959
Joined: Thu Aug 31, 2006 12:12 pm
Location: Newcastle
Has thanked: 9 times
Been thanked: 357 times
Contact:

Re: Project Green and Cream Update!!

Post by peter freeman » Wed Dec 28, 2016 10:39 pm

I assume you mean the rear frame that splits in two is a pig as the hatch seal is no problem. Come to that I did not find the other seal that much of a problem - its all in the knack you know.



User avatar
vinetvinyle
Posts: 57
Joined: Sat May 28, 2016 10:38 pm
Location: Altrincham
Has thanked: 17 times

Re: Project Green and Cream Update!!

Post by vinetvinyle » Wed Dec 28, 2016 10:57 pm

Yeh reading a bit more I'm only replacing the T seal, the outer seal on the hatch itself so trying to find something in depth but just read on the White omega scimitar project it only took him a few minutes and poking with a screwdriver so I might be alright!


[album]1671[/album]

Post Reply

Return to “Se5/5a”