SE6a coil problem!

Moderators: scimjim, philhoward, erikscimitardemon, Roger Pennington, Lukeyboy46

Post Reply
Hugh Myers
RSSOC Member
Posts: 12
Joined: Wed Jul 29, 2015 6:20 pm

SE6a coil problem!

Post by Hugh Myers » Wed Jun 13, 2018 10:16 am

OK I give up and call upon you auto electrical wizards for your advice, please!

My SE6a has a habit over overheating its coil to the point that it stops working. Changing to a spare coil sorts the problem immediately and the original one can be reused when the next change is needed so no permanent damage.
I have relocated one of the two coils fitted to a cooler area so the heat is not caused by its underbonnet location.

The car is fitted with Lumenition electronic ignition and, on the advice of a friend who had experienced a similar problem on a different car, I changed the Lumenition unit - it made no difference.

I even bought the coil and ballast resistor recommended by Lumenition for their system but then the ballast resistor overheated and fitting the original coil enabled the car to be restarted!

As far as I can see, no ballast resistor is fitted to my car so the coils in regular use are 12v.

The problem is not evident at Motorway cruising speeds but can occur pottering about the countryside or in slow traffic/queues.

Any ideas? Any recommendations of someone who can sort the problem for me?
When the coil is behaving the car is lovely but I could really do with its being reliable!
Thanks
Hugh



gtcse8
RSSOC Member
Posts: 1333
Joined: Fri Apr 24, 2009 10:11 am
Location: Steeton, Yorkshire Dales
Has thanked: 11 times
Been thanked: 74 times

SE6a coil problem!

Post by gtcse8 » Wed Jun 13, 2018 10:37 am

Hugh I believe there is a way of using lumenition either with or without a ballast, or 12v coil.

Don`t know the answer as I junk lumenition every time I see it.
It has caused me nightmares in the past.

I would suggest beg, steal or borrow a known good running points and condenser dizzy and fit it to rule out a fault in either the wiring or internals of lumenition.

Paul Slater, Laters on here, is having similar problems and he told me he has both wiring diagrams for ballast and without.

Mark


See the Beast on youtube under" RELIANT SCIMITAR CONVERSION LOL.,Se5,Se5a, Se6a, Two Se6b`s, GTC, SST 1800Ti & not a lot of sense

User avatar
DARK STAR
RSSOC Member
Posts: 5355
Joined: Tue Aug 04, 2009 8:56 pm
Location: Antibes, France
Been thanked: 59 times
Contact:

SE6a coil problem!

Post by DARK STAR » Wed Jun 13, 2018 5:26 pm

Hi Hugh, not often we hear from you so you must be desperate 8)
First of all I must say I have had Lumenition ignition on two Essex engines with no problems.
On my GTC I grilled the coil completely with a similar problem (and Ford Duraspark ignition).
Of course the 6b has the notorious eureka wire instead of a ballast resistor and mine had melted itself into the other wires causing a short circuit.
Are you sure you have no ballast resistor? because I can't see how a 12 volt system could overheat a healthy coil.
Unless ... my memory is hazy but I believe you would have a condenser in the original circuit :wink:


Chris Johnson
RSSOC 1979> Dark Star Coupé 1989> Scimitar France 2010> Vert Soleil GTC 2014>
Scimitar France Website No1 on Google, updated nearly every day

Post Reply

Return to “Se6/6a/6b/GTC”