Manny's SS1 1600

If you have a long-term project and would like to share/document progress, this is for you.

Moderators: scimjim, philhoward, erikscimitardemon, Roger Pennington, Lukeyboy46

User avatar
Alan SS1
Posts: 1874
Joined: Sun Nov 21, 2010 9:58 pm
Location: BoD, Aberdeen
Has thanked: 22 times
Been thanked: 29 times
Contact:

Manny's SS1 1600

Post by Alan SS1 » Sun Jul 08, 2018 4:16 pm

manny wrote:
Sun Jul 08, 2018 10:23 am
it failed :(
Offside Steering rack has excessive free play detected at the steering wheel.
you have more than one steering racks , that will be the problem?? just ditch it and keep the middle one :wink:


SS1 1600 (AJZ ----), Regal 330 (VAV ---), C30 (SK 57 ---)& 480 (EVU ---)

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Sun Jul 08, 2018 4:57 pm

Alan SS1 wrote:
Sun Jul 08, 2018 4:16 pm
manny wrote:
Sun Jul 08, 2018 10:23 am
it failed :(
Offside Steering rack has excessive free play detected at the steering wheel.
you have more than one steering racks , that will be the problem?? just ditch it and keep the middle one :wink:
yes ..i did not understand that either!


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Sun Jul 15, 2018 9:25 am

Good day all,

finally removed the rack last night - was not the nightmare i thought it would be - saw a stamp of 2 3 89 - late rack i guess?..

Image

Have emailed the recommended chap on the forum..

Ta

Manny

ps - car started first time as well.. :)


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Wed Jul 25, 2018 6:18 pm

Good day all,

I have a refurbished rack courtesy of Mr Wilson....however i (garage ) discovered that the TREs on my old rack did not fit - the rods on the new rack were of a thinner diameter- Mark has also now provided the suitable TREs- but we have no idea why my old rack appears to be different! - i am dropping of the new TREs to my MOT garage tomorrow .... i only hope the rest of the suspension is standard :( ..

Ta

Manny


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
Corky
RSSOC Member
Posts: 10511
Joined: Sun Sep 24, 2006 5:02 am
Location: Macclesfield
Has thanked: 115 times
Been thanked: 128 times

Manny's SS1 1600

Post by Corky » Wed Jul 25, 2018 6:33 pm

Possibly a GM rack with the wrong rods fitted?


Steve
Current:- SS1 Ti RG sprint car. VW Touareg 3.0 V6
Prev:- Sabre Ti, 3xSS1 Ti, SS1 16v Turbo Racer, 5XGTC, 2XSE6B, 2XSE5A, 2XV6 Coupe, Sabre 6
Project Threads & YouTube

“It's not the winning, it's the taking apart that counts"

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Sat Aug 04, 2018 2:20 pm

Good day all,

finally fitted a shiny good rack

Image

Car is booked in for a MOT re-test next week...hopefully i can still enjoy what's left of our current heatwave soon :)

Ta

Manny


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Mon Aug 06, 2018 7:50 pm

Good day all

my MOT retest is booked for tomorrow morning- so i thought i would check all lights etc...only to discover a strange ( to me anyway) misfire ...which will affect HCs...



i cant see the logic behind what is happening- if i push lead 4 part way towards the spark plug it seems to resolve the issue - but all the way in ..it misfires.
If unplug lead 4 - the king lead arcs - all plugs at the dizzy end are secure...new leads??

Ta

Manny
Last edited by manny on Mon Aug 06, 2018 8:47 pm, edited 1 time in total.


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
scimjim
RSSOC Member
Posts: 35465
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 113 times
Been thanked: 794 times

Manny's SS1 1600

Post by scimjim » Mon Aug 06, 2018 8:26 pm

Yep, I think the two are unrelated. The king lead is arcing when you move it because the insulation has gone and number 4 looks like the metal connector is loose (have you also checked that the screw on cap on the plug is tight?)


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Mon Aug 06, 2018 8:42 pm

scimjim wrote:
Mon Aug 06, 2018 8:26 pm
Yep, I think the two are unrelated. The king lead is arcing when you move it because the insulation has gone and number 4 looks like the metal connector is loose (have you also checked that the screw on cap on the plug is tight?)
fixed!! :D ...i think new leads will be a good idea..i swapped no4 lead with a good (short) one from the GTE - the misfire was still there..i then checked the spark plug ..it was heavily carbon coated..i cleaned it and all was well....italian tune up to the MOT me thinks..

Ta

Manny

ps will these do?

Spark leads


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
Roger Pennington
RSSOC Member
Posts: 19183
Joined: Tue Aug 29, 2006 9:43 pm
Has thanked: 109 times
Been thanked: 442 times

Manny's SS1 1600

Post by Roger Pennington » Mon Aug 06, 2018 8:51 pm

I had a similar problem with the leads arcing - not just at the king lead, but in several places where the leads were in contact. I replaced them with some Bosch silicone ones, which seem to have been ok. When I replaced them I also made sure that the leads didn't come into contact or overlap each other (unfortunately you can't see the dizzy in the photo - not surprisingly!)

Leads 01.jpg
Leads 01.jpg (150.44 KiB) Viewed 457 times


....Roger

RSSOC member (since 1982)
- - - - - - - - - - - - - - - - -
Image

"Condition can be bought at any time; Originality, once lost, is gone forever" - Doug Nye

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Mon Aug 06, 2018 9:00 pm

Roger Pennington wrote:
Mon Aug 06, 2018 8:51 pm
I had a similar problem with the leads arcing - not just at the king lead, but in several places where the leads were in contact. I replaced them with some Bosch silicone ones, which seem to have been ok. When I replaced them I also made sure that the leads didn't come into contact or overlap each other (unfortunately you can't see the dizzy in the photo - not surprisingly!)
very neat ...forgive me....what is that black contraption on your heater water pipe??


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

User avatar
scimjim
RSSOC Member
Posts: 35465
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 113 times
Been thanked: 794 times

Manny's SS1 1600

Post by scimjim » Mon Aug 06, 2018 9:01 pm

You can go for Magnecor at £70 ish or cheapies at £20. I’d go for something branded like these personally (I’d offer something like £25?)


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
Alan SS1
Posts: 1874
Joined: Sun Nov 21, 2010 9:58 pm
Location: BoD, Aberdeen
Has thanked: 22 times
Been thanked: 29 times
Contact:

Manny's SS1 1600

Post by Alan SS1 » Tue Aug 07, 2018 1:06 pm

manny wrote:
Mon Aug 06, 2018 9:00 pm
Roger Pennington wrote:
Mon Aug 06, 2018 8:51 pm
I had a similar problem with the leads arcing - not just at the king lead, but in several places where the leads were in contact. I replaced them with some Bosch silicone ones, which seem to have been ok. When I replaced them I also made sure that the leads didn't come into contact or overlap each other (unfortunately you can't see the dizzy in the photo - not surprisingly!)
very neat ...forgive me....what is that black contraption on your heater water pipe??
on/off valve? see the bowden cable poking through bulk-head?


SS1 1600 (AJZ ----), Regal 330 (VAV ---), C30 (SK 57 ---)& 480 (EVU ---)

User avatar
Roger Pennington
RSSOC Member
Posts: 19183
Joined: Tue Aug 29, 2006 9:43 pm
Has thanked: 109 times
Been thanked: 442 times

Manny's SS1 1600

Post by Roger Pennington » Tue Aug 07, 2018 2:28 pm

manny wrote:
Mon Aug 06, 2018 9:00 pm
very neat ...forgive me....what is that black contraption on your heater water pipe??
Thanks, yes the black thing in the water pipe is the water valve to control the flow of water through the heater. I normally leave it set to "on" to keep the flow of water going, though it does get roastingly hot if you have the hood up in the rain in summer.


....Roger

RSSOC member (since 1982)
- - - - - - - - - - - - - - - - -
Image

"Condition can be bought at any time; Originality, once lost, is gone forever" - Doug Nye

User avatar
manny
RSSOC Member
Posts: 1017
Joined: Sat Sep 29, 2012 10:11 pm
Location: Smethwick, West Midlands
Has thanked: 30 times
Been thanked: 14 times

Manny's SS1 1600

Post by manny » Wed Aug 08, 2018 6:42 pm

Good day all,

MOT in hand :D :D :D :D
i cant speak of 'my' garage highly enough!! they did not want to charge for the full MOT retest, attending to the steering rack twice!, the re-tracking and putting straight my attempt at the steering wheel..!!...but as i don't like freebies - i had to 'convince' them to at least take the charge of retest - that took me 25 mins!!

i have two advisories that are on my list next

So a journey to Mr Wilson's on the weekend - give it a good run and pick up a HT
:D :D

Ta

Manny


GTE Progress#
Ti Progress#
1600 Progress#
GTC Progress#
Tr7 V8 1982 #Bajaj Legend NXT ( Vespa)#bicycle 2010

Post Reply

Return to “Project Progress”