G97 - zetec inside

If you have a long-term project and would like to share/document progress, this is for you.

Moderators: scimjim, Lukeyboy46, erikscimitardemon, Roger Pennington, philhoward

Dcrosby13
RSSOC Member
Posts: 1403
Joined: Mon Mar 28, 2016 5:28 pm
Location: Warrington
Has thanked: 30 times
Been thanked: 89 times

G97 - zetec inside

Post by Dcrosby13 » Thu Mar 14, 2019 8:43 pm

I'd be happy just to be a passenger 😁


I break stuff...... :w

User avatar
scimjim
RSSOC Member
Posts: 38550
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 154 times
Been thanked: 1051 times

G97 - zetec inside

Post by scimjim » Fri Mar 15, 2019 10:34 pm

I took two days off work to get Bens Sabre out of stairage yesterday and help a friend take his project Herald into town for paint today - which meant I got two extra half days on G97 :D
scimjim wrote:
Thu Mar 14, 2019 8:34 pm
New list to make test day looks like this

Plumb in remote oil filter
Finish plumbing in cooling system (8mm breather pipe)
Fit fuel rail (needs new o-rings)
Fit inlet manifold (waiting for fuel rail o-rings)
Fit alternator tensioner bracket
Fill engine with oil
Fit crossbeam and protec dampers (modify to 1/2” bolts)
Sort Megasquirt map
Refit drivers door card
Refit bonnet
Refit bootlid
Missed off replace accelerator pedal that I bodged last season (did today) and fit new cable (also done).

Fitted the dampers, remote oil filter and finished off the coolant hoses. Hopefully the o-rings that Phil has will fit when he comes down to collect C686 tomorrow, and I can get G97 started.


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
MikeyBikey
Posts: 6081
Joined: Thu Mar 11, 2010 1:55 pm
Location: Sunny Falmouth. :)
Has thanked: 324 times
Been thanked: 156 times

G97 - zetec inside

Post by MikeyBikey » Sat Mar 16, 2019 9:43 am

Great stuff Jim.


Is we sideways yet...

User avatar
scimjim
RSSOC Member
Posts: 38550
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 154 times
Been thanked: 1051 times

G97 - zetec inside

Post by scimjim » Sat Mar 16, 2019 8:46 pm

Another few hours today with Phil’s help after we’d moved everything out to get C686 out and put them all back.

Unfortunately we have a lack of fuel and a sluggish starter, so still plenty of work to do tomorrow if it’s going to make test day.


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

efi_sprintgte
RSSOC Member
Posts: 1462
Joined: Fri Oct 22, 2010 6:24 pm
Location: Sutton, Surrey
Has thanked: 191 times
Been thanked: 102 times

G97 - zetec inside

Post by efi_sprintgte » Sun Mar 17, 2019 6:55 am

Good luck Jim


JC

User avatar
scimjim
RSSOC Member
Posts: 38550
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 154 times
Been thanked: 1051 times

G97 - zetec inside

Post by scimjim » Sun Mar 17, 2019 9:17 pm

So it’s back in one piece and I fitted the alternator tensioner - but it still won’t start.

Spent almost all day checking the wiring and came to the conclusion that the injector drivers are toast. I have fuel pressure and can jury rig a supply to make the injectors fire, I have continuity from each injector wire back to the ECU and the tunerstudio says it’s trying to fire them - but still no fuel :(


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

efi_sprintgte
RSSOC Member
Posts: 1462
Joined: Fri Oct 22, 2010 6:24 pm
Location: Sutton, Surrey
Has thanked: 191 times
Been thanked: 102 times

G97 - zetec inside

Post by efi_sprintgte » Sun Mar 17, 2019 10:10 pm

What’s the voltage at the CPS?

Edit - whilst cranking I mean


JC

User avatar
Corky
RSSOC Member
Posts: 11364
Joined: Sun Sep 24, 2006 5:02 am
Location: Macclesfield
Has thanked: 294 times
Been thanked: 228 times

G97 - zetec inside

Post by Corky » Sun Mar 17, 2019 10:14 pm

Nightmare!

Good luck getting it sorted.


Steve
Current:- SS1 Ti RG sprint car, Honda S2000, VW Touareg 3.0 V6
Prev:- Sabre Ti, 3xSS1 Ti, SS1 16v Turbo Racer, 5XGTC, 2XSE6B, 2XSE5A, 2XV6 Coupe, Sabre 6
Project Threads & YouTube

“It's not the winning, it's the taking apart that counts"

User avatar
scimjim
RSSOC Member
Posts: 38550
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 154 times
Been thanked: 1051 times

G97 - zetec inside

Post by scimjim » Sun Mar 17, 2019 10:30 pm

efi_sprintgte wrote:
Sun Mar 17, 2019 10:10 pm
What’s the voltage at the CPS?

Edit - whilst cranking I mean
cant remember if I checked it while cranking but full battery voltage with ignition on. What would low/no voltage during cranking indicate other than driver failure?


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

User avatar
philhoward
RSSOC Member
Posts: 25800
Joined: Tue Aug 29, 2006 5:41 pm
Location: Staffs, UK
Has thanked: 77 times
Been thanked: 706 times
Contact:

G97 - zetec inside

Post by philhoward » Mon Mar 18, 2019 12:37 am

efi_sprintgte wrote:
Sun Mar 17, 2019 10:10 pm
What’s the voltage at the CPS?

Edit - whilst cranking I mean
It’s running EDIS for sparks and was sparking successfully on Saturday and I could see a stable reading for RPM and injector PW so confident it isn’t suffering resets from low voltage.


Phil Howard
Scimitarweb Forum Admin
SS1 1600 Rooster Turbo; Sabre Mk1.5, Sabre Mk2
Previous: SE5/5a/SS1 No.1/SS1 Rooster/SS1 1800Ti/SE5a 24 Valve
http://www.ss1turbo.com
Never try and argue with an idiot. They drag you down to their level, then beat you based on experience.

efi_sprintgte
RSSOC Member
Posts: 1462
Joined: Fri Oct 22, 2010 6:24 pm
Location: Sutton, Surrey
Has thanked: 191 times
Been thanked: 102 times

G97 - zetec inside

Post by efi_sprintgte » Mon Mar 18, 2019 6:17 am

philhoward wrote:
Mon Mar 18, 2019 12:37 am
It’s running EDIS for sparks and was sparking successfully on Saturday and I could see a stable reading for RPM and injector PW so confident it isn’t suffering resets from low voltage.

Cool, I’ve been caught out before.


JC

User avatar
scimjim
RSSOC Member
Posts: 38550
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 154 times
Been thanked: 1051 times

G97 - zetec inside

Post by scimjim » Sat Mar 23, 2019 5:35 pm

So we tried another Megasquirt and got it started - proving that mine has a problem. Unfortunately we had an oil problem which I didn’t notice until it had 30 seconds at 3000rpm - turned it off but the bottom end had siezed :(

I found a 1.8 engine recently removed from a mondeo - which luckily was on my route back from a meeting on Wednesday, so this happened:
183DB81A-8D1F-4718-9601-0E42301DE67A.jpeg
183DB81A-8D1F-4718-9601-0E42301DE67A.jpeg (285.3 KiB) Viewed 1829 times
FEB9B12D-05F2-44AE-8499-BABA55DA2AD3.jpeg
FEB9B12D-05F2-44AE-8499-BABA55DA2AD3.jpeg (203.62 KiB) Viewed 1829 times


Jim King

SECURE DRY STORAGE FOR YOUR SCIMITAR

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), 1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

Dcrosby13
RSSOC Member
Posts: 1403
Joined: Mon Mar 28, 2016 5:28 pm
Location: Warrington
Has thanked: 30 times
Been thanked: 89 times

G97 - zetec inside

Post by Dcrosby13 » Sat Mar 23, 2019 5:51 pm

Glad you got it sorted, are you stripping it before use or giving it a go as it is?


I break stuff...... :w

User avatar
philhoward
RSSOC Member
Posts: 25800
Joined: Tue Aug 29, 2006 5:41 pm
Location: Staffs, UK
Has thanked: 77 times
Been thanked: 706 times
Contact:

G97 - zetec inside

Post by philhoward » Sat Mar 23, 2019 5:52 pm

Too late - that’s the replacement already in! Internals looked very clean so winging it.


Phil Howard
Scimitarweb Forum Admin
SS1 1600 Rooster Turbo; Sabre Mk1.5, Sabre Mk2
Previous: SE5/5a/SS1 No.1/SS1 Rooster/SS1 1800Ti/SE5a 24 Valve
http://www.ss1turbo.com
Never try and argue with an idiot. They drag you down to their level, then beat you based on experience.

User avatar
MikeyBikey
Posts: 6081
Joined: Thu Mar 11, 2010 1:55 pm
Location: Sunny Falmouth. :)
Has thanked: 324 times
Been thanked: 156 times

G97 - zetec inside

Post by MikeyBikey » Sun Mar 24, 2019 9:09 am

Blimey, bad luck mate. Keep at it.


Is we sideways yet...

Post Reply

Return to “Project Progress”