Swoakes SS1 DET Sprint Car misfire

If you have a long-term project and would like to share/document progress, this is for you.

Moderators: scimjim, Lukeyboy46, erikscimitardemon, Roger Pennington, philhoward

User avatar
Corky
RSSOC Member
Posts: 10993
Joined: Sun Sep 24, 2006 5:02 am
Location: Macclesfield
Has thanked: 174 times
Been thanked: 176 times

Swoakes SS1 DET Sprint Car misfire

Post by Corky » Mon May 13, 2019 5:43 pm

Fingers crossed, that was your problem.


Steve
Current:- SS1 Ti RG sprint car, Honda S2000, VW Touareg 3.0 V6
Prev:- Sabre Ti, 3xSS1 Ti, SS1 16v Turbo Racer, 5XGTC, 2XSE6B, 2XSE5A, 2XV6 Coupe, Sabre 6
Project Threads & YouTube

“It's not the winning, it's the taking apart that counts"

User avatar
CNHSS1
RSSOC Member
Posts: 14126
Joined: Tue Aug 22, 2006 5:13 pm
Location: Shrewsbury, Shropshire
Has thanked: 308 times
Been thanked: 244 times
Contact:

Swoakes SS1 DET Sprint Car misfire

Post by CNHSS1 » Mon May 13, 2019 6:06 pm

Yup fingers crossed old plugs were the issue :)


Racing is life, everything before and after, is just waiting--Steve McQueen
6 time Class Champ, 2006 & 2014 SSSC Champion

RIP Batmobile, await the Rise of Dark Knight 8)
Sabre 'Light Sabre' 360hp!!
Image

User avatar
swoakes
RSSOC Member
Posts: 6827
Joined: Thu Sep 21, 2006 12:23 pm
Location: Cheshire, UK
Has thanked: 29 times
Been thanked: 88 times

Swoakes SS1 DET Sprint Car misfire

Post by swoakes » Mon May 13, 2019 6:12 pm

CNHSS1 wrote:
Mon May 13, 2019 6:06 pm
Yup fingers crossed old plugs were the issue :)
They were new pre event Craig but maybe it was damaged already and I didn't notice or we cracked it on Sunday when we removed the plugs after the car cut out on track (earth feed to ignition relay broken)


Steve Oakes
SS1 DET Sprint Car

Former cars
SS1 DET Turbo sprint Project
Sabre Ti
SS1 Ti
1971 Yellow 5a
1985 SS1 1600
1978 Green/Silver 6a

Image
"Fail to prepare and you are preparing to fail."
Benjamin Franklin

efi_sprintgte
RSSOC Member
Posts: 1228
Joined: Fri Oct 22, 2010 6:24 pm
Location: Sutton, Surrey
Has thanked: 97 times
Been thanked: 65 times

Swoakes SS1 DET Sprint Car misfire

Post by efi_sprintgte » Mon May 13, 2019 7:20 pm

Ironically we had a misfire at Debden from a cracked plug too, again they were brand new


JC

User avatar
CNHSS1
RSSOC Member
Posts: 14126
Joined: Tue Aug 22, 2006 5:13 pm
Location: Shrewsbury, Shropshire
Has thanked: 308 times
Been thanked: 244 times
Contact:

Swoakes SS1 DET Sprint Car misfire

Post by CNHSS1 » Mon May 13, 2019 8:22 pm

swoakes wrote:
Mon May 13, 2019 6:12 pm
CNHSS1 wrote:
Mon May 13, 2019 6:06 pm
Yup fingers crossed old plugs were the issue :)
They were new pre event Craig but maybe it was damaged already and I didn't notice or we cracked it on Sunday when we removed the plugs after the car cut out on track (earth feed to ignition relay broken)
*cough* clumsy bugger, should've gone to Spec Savers :lol: *cough*

Hoped it wasnt a case of short arms and long pockets, eeking out last seasons plugs... :mrgreen:


Racing is life, everything before and after, is just waiting--Steve McQueen
6 time Class Champ, 2006 & 2014 SSSC Champion

RIP Batmobile, await the Rise of Dark Knight 8)
Sabre 'Light Sabre' 360hp!!
Image

User avatar
CNHSS1
RSSOC Member
Posts: 14126
Joined: Tue Aug 22, 2006 5:13 pm
Location: Shrewsbury, Shropshire
Has thanked: 308 times
Been thanked: 244 times
Contact:

Swoakes SS1 DET Sprint Car misfire

Post by CNHSS1 » Mon May 13, 2019 8:25 pm

To be fair, modern plugs, or at least modern (proper) ignition systems do seem intolerant of plugs. I've never had any joy cleaning plugs, whereas back in the day you could wire brush them, wipe them on your Jean's and they'd run lovely again


Racing is life, everything before and after, is just waiting--Steve McQueen
6 time Class Champ, 2006 & 2014 SSSC Champion

RIP Batmobile, await the Rise of Dark Knight 8)
Sabre 'Light Sabre' 360hp!!
Image

User avatar
swoakes
RSSOC Member
Posts: 6827
Joined: Thu Sep 21, 2006 12:23 pm
Location: Cheshire, UK
Has thanked: 29 times
Been thanked: 88 times

Swoakes SS1 DET Sprint Car misfire

Post by swoakes » Mon May 13, 2019 9:01 pm

CNHSS1 wrote:
Mon May 13, 2019 8:22 pm
swoakes wrote:
Mon May 13, 2019 6:12 pm
CNHSS1 wrote:
Mon May 13, 2019 6:06 pm
Yup fingers crossed old plugs were the issue :)
They were new pre event Craig but maybe it was damaged already and I didn't notice or we cracked it on Sunday when we removed the plugs after the car cut out on track (earth feed to ignition relay broken)
*cough* clumsy bugger, should've gone to Spec Savers :lol: *cough*

Hoped it wasnt a case of short arms and long pockets, eeking out last seasons plugs... :mrgreen:
:lol:

No they were a new set.

I broke one today by using too short an extension bar. As you know the plugs are deep in the head and I must have put some lateral force on the plug. The ceramic cracked big style :roll:


Steve Oakes
SS1 DET Sprint Car

Former cars
SS1 DET Turbo sprint Project
Sabre Ti
SS1 Ti
1971 Yellow 5a
1985 SS1 1600
1978 Green/Silver 6a

Image
"Fail to prepare and you are preparing to fail."
Benjamin Franklin

User avatar
swoakes
RSSOC Member
Posts: 6827
Joined: Thu Sep 21, 2006 12:23 pm
Location: Cheshire, UK
Has thanked: 29 times
Been thanked: 88 times

Swoakes SS1 DET Sprint Car misfire

Post by swoakes » Thu May 16, 2019 4:51 pm

Update.

Car went to the rolling road today and NO misfire :) Must have been that plug :roll:

On the downside looking at the curves it looks like the oil leak from the rear crank seal has contaminated the clutch.

So it will be engine out after Harewood and new clutch....paddle or uprated standard :?: :w


Steve Oakes
SS1 DET Sprint Car

Former cars
SS1 DET Turbo sprint Project
Sabre Ti
SS1 Ti
1971 Yellow 5a
1985 SS1 1600
1978 Green/Silver 6a

Image
"Fail to prepare and you are preparing to fail."
Benjamin Franklin

Post Reply

Return to “Project Progress”