SE5A Project - Swindon

If you have a long-term project and would like to share/document progress, this is for you.

Moderators: scimjim, philhoward, erikscimitardemon, Roger Pennington, Lukeyboy46

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Mon Jun 04, 2018 8:38 am

Will, it certainly does. More than 500rpm, and makes for a much quieter cruise at legal speeds.

Cheers

Steve


SE5a 'Fancier'

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Mon Jun 18, 2018 7:53 am

Quite pleased this week to have finally identified the colour of my Scimitar SE5a. A non-original Russet Red (3515).

Might be a BL colour from back in the day, but not really sure.

However a good match for touch-ups.

And now, at least I can start repairing all the stone chips and collateral damage received whilst carrying out recent works. No to mention a tidy up the engine bay.

Not that there is that much life left in the current paint job, but at least I can extend its life a little before taking the plunge with a re-spray down the line..

Steve


SE5a 'Fancier'

User avatar
scimjim
RSSOC Member
Posts: 34858
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 112 times
Been thanked: 756 times

SE5A Project - Swindon

Post by scimjim » Mon Jun 18, 2018 8:50 am

Russet red is a standard SE6 colour.


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Mon Jun 18, 2018 10:13 am

Thanks Jim, that makes a lot of sense. As you know it was that dark brown originally. As one of the last SE5a's, it sat around in the showroom and did not sell for a while, not being registered till well into 1976. I understand that the SE6s were being sold by that time, so it was probably difficult to shift considering its unfortunate colour and the newer model being out.

You never know, it might have been repainted to sell? Fanciful thinking, I know. Still, although brown seems to be an unfortunate colour now, perhaps it was all the rage then.

I had a Morris Ital that colour. I could fit 6 airmen in it on the way to the pub, plus me, the driver. We were all a bit skinnier in those days.

Cheers

Steve


SE5a 'Fancier'

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Tue Jul 03, 2018 10:35 pm

Ah well,

My turn to break down tonight. On the way home I lost the ignition. When I turned the ignition on there was no red light in the speedo. The engine will crank and try to start. But the moment you release the key to disengage the starter, the engine stops. So it looks like the ignition switch/barrel has failed at position II. AA man turned up and we put 12v onto the coil, which got me going again, but there was no charging. So I just made it home.

So is it the ignition switch, and can I get another? I assume it's an arse of a job to do?

Cheers

Steve


SE5a 'Fancier'

gtcse8
RSSOC Member
Posts: 1236
Joined: Fri Apr 24, 2009 10:11 am
Location: Steeton, Yorkshire Dales
Has thanked: 8 times
Been thanked: 64 times

SE5A Project - Swindon

Post by gtcse8 » Tue Jul 03, 2018 10:47 pm

Steve I keep NEW ignition switches in stock which consists of the lock itself and the switching unit.
The switching units are held into the lock unit with a small self tapper.
The switch is only £25 inc post if that is what you need.
ignition switches.JPG
ignition switches.JPG (158.16 KiB) Viewed 315 times


See the Beast on youtube under" RELIANT SCIMITAR CONVERSION LOL.,Se5,Se5a, Se6a, Two Se6b`s, GTC, SST 1800Ti & not a lot of sense

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Tue Jul 03, 2018 10:59 pm

Sounds like just what I need. Be in touch tomorrow to sort out details, assuming that that is indeed my issue, which I have not yet confirmed with a multimeter. Although it seems highly likely.

Steve


SE5a 'Fancier'

willholderogri
RSSOC Member
Posts: 724
Joined: Sat Aug 21, 2010 10:47 pm
Location: chippenham
Has thanked: 64 times
Been thanked: 17 times

SE5A Project - Swindon

Post by willholderogri » Wed Jul 04, 2018 8:01 am

hi steve yes if its not charging with a by pass its the supply to the dash/alternator light that is the problem (most likely the switch)
Mine split a pipe this morning now on the bike for three days


1962 mini, bedford CA , KR200. morris 1000, mini pickup.several escorts,ford grandad.ford cortina X2 ,astra, SE5A x 2 ,ford focus.

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Fri Jul 06, 2018 6:59 pm

I needed to get the old girl running again, so for the time being I removed my switch and have attempted to rebuild it, by cleaning it , and putting a bit of solder on the pitted contacts to build them up a bit. I put it back together with a bit of petroleum jelly to smooth it's operation. It seems to work. I could not find any screws to locate the switch unit, just key/slot for alignment. So I have secured with some tiewraps.

Normal service resumed, at least on the drive way. Take it for a run shortly.

The switches pictured have only 4 wires leading from them, whereas mine has 6. And I could not find the plug on my car?

Wiltshire Noggin on Monday


SE5a 'Fancier'

gtcse8
RSSOC Member
Posts: 1236
Joined: Fri Apr 24, 2009 10:11 am
Location: Steeton, Yorkshire Dales
Has thanked: 8 times
Been thanked: 64 times

SE5A Project - Swindon

Post by gtcse8 » Fri Jul 06, 2018 8:05 pm

Steve I posted one of the new switches out to you to try.

Sounds like a wasted trip to the Postoffice.

I`m confused that yours has 6 wires and no plug or self tapper.

Sounds like its been modified somewhat.


See the Beast on youtube under" RELIANT SCIMITAR CONVERSION LOL.,Se5,Se5a, Se6a, Two Se6b`s, GTC, SST 1800Ti & not a lot of sense

Rev Light
RSSOC Member
Posts: 493
Joined: Sat Nov 14, 2015 12:54 pm
Location: Swindon
Has thanked: 5 times
Been thanked: 19 times

SE5A Project - Swindon

Post by Rev Light » Fri Jul 06, 2018 9:45 pm

I would not be surprised, quite frankly. The are plenty of 'modifications' - blue chock blocks and terminated wires, some just cut. Extra wires that bypass original circuit, etc. I am going to pull the dash soon and sort it all out. With this in mind, I might just keep the new switch and use it when I get to grips with this project.

Steve


SE5a 'Fancier'

Post Reply

Return to “Project Progress”